Merge remote-tracking branch 'jirutka/lxc-grsec'
[gentoo.git] / net-misc / rdesktop / rdesktop-1.8.2.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit autotools eutils
8
9 MY_PV=${PV/_/-}
10
11 DESCRIPTION="A Remote Desktop Protocol Client"
12 HOMEPAGE="http://rdesktop.sourceforge.net/"
13 SRC_URI="mirror://sourceforge/${PN}/${PN}-${MY_PV}.tar.gz"
14
15 LICENSE="GPL-3"
16 SLOT="0"
17 KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
18 IUSE="alsa ao debug ipv6 kerberos libsamplerate oss pcsc-lite"
19
20 S=${WORKDIR}/${PN}-${MY_PV}
21
22 RDEPEND=">=dev-libs/openssl-0.9.6b
23         x11-libs/libX11
24         x11-libs/libXext
25         x11-libs/libXau
26         x11-libs/libXdmcp
27         alsa? ( media-libs/alsa-lib )
28         ao? ( >=media-libs/libao-0.8.6 )
29         kerberos? ( net-libs/libgssglue )
30         libsamplerate? ( media-libs/libsamplerate )
31         pcsc-lite? ( >=sys-apps/pcsc-lite-1.6.6 )"
32 DEPEND="${RDEPEND}
33         virtual/pkgconfig
34         x11-libs/libXt"
35
36 src_prepare() {
37         # Prevent automatic stripping
38         local strip="$(echo '$(STRIP) $(DESTDIR)$(bindir)/rdesktop')"
39         sed -i -e "s:${strip}::" Makefile.in \
40                 || die "sed failed in Makefile.in"
41
42         # Automagic dependency on libsamplerate
43         epatch "${FILESDIR}"/${PN}-1.6.0-sound_configure.patch
44         # bug #280923
45         epatch "${FILESDIR}"/${PN}-1.7.0-libao_crash.patch
46
47         epatch_user
48
49         eautoreconf
50 }
51
52 src_configure() {
53         if use ao; then
54                 sound_conf=$(use_with ao sound libao)
55         else if use alsa; then
56                         sound_conf=$(use_with alsa sound alsa)
57                 else
58                         sound_conf=$(use_with oss sound oss)
59                 fi
60         fi
61
62         econf \
63                 --with-openssl="${EPREFIX}"/usr \
64                 $(use_with debug) \
65                 $(use_with ipv6) \
66                 $(use_with libsamplerate) \
67                 $(use_enable kerberos credssp) \
68                 $(use_enable pcsc-lite smartcard) \
69                 ${sound_conf}
70 }
71
72 src_install() {
73         emake DESTDIR="${D}" install
74         dodoc doc/HACKING doc/TODO doc/keymapping.txt
75
76         # For #180313 - applies to versions >= 1.5.0
77         # Fixes sf.net bug
78         # http://sourceforge.net/tracker/index.php?func=detail&aid=1725634&group_id=24366&atid=381349
79         # check for next version to see if this needs to be removed
80         insinto /usr/share/rdesktop/keymaps
81         newins "${FILESDIR}/rdesktop-keymap-additional" additional
82         newins "${FILESDIR}/rdesktop-keymap-cs" cs
83         newins "${FILESDIR}/rdesktop-keymap-sk" sk
84 }