app-editors/kakoune: drop old 0_pre20160620
[gentoo.git] / net-misc / pyhoca-gui / pyhoca-gui-0.5.0.7.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 )
7 inherit distutils-r1
8
9 DESCRIPTION="X2Go graphical client applet"
10 HOMEPAGE="http://www.x2go.org"
11 SRC_URI="http://code.x2go.org/releases/source/${PN}/${P}.tar.gz"
12
13 LICENSE="AGPL-3"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 RDEPEND="dev-python/notify-python[${PYTHON_USEDEP}]
19         dev-python/pycups[${PYTHON_USEDEP}]
20         dev-python/setproctitle[${PYTHON_USEDEP}]
21         dev-python/wxpython[${PYTHON_USEDEP}]
22         >=net-misc/python-x2go-0.5.0.0[${PYTHON_USEDEP}]"
23 DEPEND="${DEPEND}
24         dev-python/python-distutils-extra[${PYTHON_USEDEP}]"
25
26 python_install() {
27         distutils-r1_python_install
28         python_doscript ${PN}
29 }
30
31 python_install_all() {
32         distutils-r1_python_install_all
33         doman man/man1/*
34 }