1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
6 inherit autotools eutils gnome2-utils toolchain-funcs
8 DESCRIPTION="A Free Telnet/SSH Client"
9 HOMEPAGE="http://www.chiark.greenend.org.uk/~sgtatham/putty/"
13 KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
14 IUSE="doc +gtk ipv6 kerberos"
16 https://dev.gentoo.org/~jer/${PN}-icons.tar.bz2
17 http://the.earth.li/~sgtatham/${PN}/latest/${P}.tar.gz
29 kerberos? ( virtual/krb5 )
39 -e '/AM_PATH_GTK(/d' \
49 $(use_with kerberos gssapi) \
55 emake AR=$(tc-getAR) $(usex ipv6 '' COMPAT=-DNO_IPV6)
59 dodoc doc/puttydoc.txt
69 for i in 16 22 24 32 48 64 128 256; do
70 newicon -s ${i} "${WORKDIR}"/${PN}-icons/${PN}-${i}.png ${PN}.png
73 # install desktop file provided by Gustav Schaffter in #49577
74 make_desktop_entry ${PN} PuTTY ${PN} Network
79 use gtk && gnome2_icon_savelist
83 use gtk && gnome2_icon_cache_update
87 use gtk && gnome2_icon_cache_update