app-editors/kakoune: drop old 0_pre20160620
[gentoo.git] / net-misc / proxytunnel / proxytunnel-1.9.1-r1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5
6 inherit flag-o-matic toolchain-funcs
7
8 DESCRIPTION="Connect stdin and stdout to a server somewhere on the network, through a standard HTTPS proxy"
9 HOMEPAGE="https://github.com/proxytunnel/proxytunnel/ http://proxytunnel.sourceforge.net/"
10 SRC_URI="https://github.com/proxytunnel/proxytunnel/archive/${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
15 IUSE="static"
16
17 RDEPEND="dev-libs/openssl:="
18 DEPEND="${RDEPEND}
19         virtual/pkgconfig
20         app-text/asciidoc
21         app-text/xmlto
22         "
23
24 src_prepare() {
25         sed -i -e 's/libssl/libssl libcrypto/' Makefile || die "Sed failed!"
26         epatch "${FILESDIR}"/${PN}-allowTLS.patch
27 }
28
29 src_compile() {
30         use static && append-ldflags -static
31         emake CC="$(tc-getCC)" || die
32 }
33
34 src_install() {
35         emake install prefix="${EPREFIX}"/usr DESTDIR="${D}" || die
36         dodoc CHANGES CREDITS INSTALL KNOWN_ISSUES LICENSE.txt README RELNOTES TODO
37 }