sys-process/glances: revbump 3.1.4.1, add missing doc dep
[gentoo.git] / net-misc / proxytunnel / proxytunnel-1.10.20200507.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit flag-o-matic toolchain-funcs
7
8 DESCRIPTION="Connect stdin and stdout to a server via an HTTPS proxy"
9 HOMEPAGE="https://github.com/proxytunnel/proxytunnel/ https://proxytunnel.sourceforge.net/"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 IUSE="static"
14
15 RDEPEND="dev-libs/openssl:="
16 DEPEND="${RDEPEND}
17         app-text/asciidoc
18         app-text/xmlto
19         "
20 BDEPEND="virtual/pkgconfig"
21
22 DOCS=( CHANGES CREDITS INSTALL KNOWN_ISSUES LICENSE.txt README RELNOTES TODO )
23
24 if [[ ${PV} == *9999 ]] ; then
25         EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
26         inherit git-r3
27 else
28         SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
29         KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
30 fi
31
32 src_prepare() {
33         default
34         sed -i -e 's/libssl/libssl libcrypto/' Makefile || die "Sed failed!"
35 }
36
37 src_compile() {
38         use static && append-ldflags -static
39         emake CC="$(tc-getCC)"
40 }
41
42 src_install() {
43         emake install prefix="${EPREFIX}"/usr DESTDIR="${D}"
44         einstalldocs
45 }