sys-process/glances: revbump 3.1.4.1, add missing doc dep
[gentoo.git] / net-misc / proxychains / proxychains-4.14.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit toolchain-funcs
7
8 MY_PN=${PN}-ng
9 MY_P=${MY_PN}-${PV}
10
11 DESCRIPTION="force any tcp connections to flow through a proxy (or proxy chain)"
12 HOMEPAGE="https://github.com/rofl0r/proxychains-ng/"
13 SRC_URI="http://ftp.barfooze.de/pub/sabotage/tarballs/${MY_P}.tar.xz"
14
15 LICENSE="GPL-2"
16 SLOT="0"
17 KEYWORDS="~amd64 ~ppc ~sparc ~x86"
18
19 S=${WORKDIR}/${MY_P}
20
21 PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
22
23 src_prepare() {
24         default
25         sed -i "s/^\(LDSO_SUFFIX\).*/\1 = so.${PV}/" Makefile || die
26         tc-export CC
27 }
28
29 src_configure() {
30         # not autotools
31         ./configure \
32                 --prefix="${EPREFIX}"/usr \
33                 --libdir="${EPREFIX}"/usr/$(get_libdir) \
34                 --sysconfdir="${EPREFIX}"/etc \
35                 || die
36 }
37
38 src_install() {
39         dobin ${PN}
40         dodoc AUTHORS README TODO
41
42         dolib.so lib${PN}.so.${PV}
43         dosym lib${PN}.so.${PV} /usr/$(get_libdir)/lib${PN}.so.${PV:0:1}
44         dosym lib${PN}.so.${PV} /usr/$(get_libdir)/lib${PN}.so
45
46         insinto /etc
47         doins src/${PN}.conf
48 }