app-editors/kakoune: drop old 0_pre20160620
[gentoo.git] / net-misc / pmsvn / pmsvn-1.0.6.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 DESCRIPTION="Server's configuration management and monitoring tool"
7 HOMEPAGE="https://sourceforge.net/projects/pmsvn/"
8 SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
9
10 LICENSE="GPL-3"
11 SLOT="0"
12 KEYWORDS="~amd64 ~x86"
13 IUSE=""
14
15 DEPEND=""
16 RDEPEND="net-analyzer/nrpe
17         >=app-shells/bash-4.0_p37
18         >=sys-apps/sed-4.2
19         >=dev-vcs/subversion-1.6.9"
20
21 S="${WORKDIR}"
22
23 src_prepare() {
24         # move configuration file from /etc/${PN}.conf to /etc/${PN}/${PN}.conf
25         sed -i "/etc\/${PN}.conf/s:etc/${PN}.conf:etc/${PN}/${PN}.conf:" ${PN} \
26                 || die "failed to fix path for configuration file"
27 }
28
29 src_install() {
30         dosbin "${PN}"
31         dodoc README
32         # No sample file anymore. Autogenerated on first execution
33         # insinto /etc/${PN}/
34         # doins pmsvn.conf.sample
35 }