app-editors/kakoune: drop old 0_pre20160620
[gentoo.git] / net-misc / networkmanager-libreswan / networkmanager-libreswan-1.2.6.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 GNOME_ORG_MODULE="NetworkManager-libreswan"
6
7 inherit gnome2
8
9 DESCRIPTION="NetworkManager libreswan plugin"
10 HOMEPAGE="https://wiki.gnome.org/Projects/NetworkManager/VPN"
11
12 LICENSE="GPL-2+"
13 SLOT="0"
14 KEYWORDS="~amd64 x86"
15 IUSE="gtk"
16
17 RDEPEND="
18         >=dev-libs/glib-2.32:2
19         >=dev-libs/libnl-3.2.8:3
20         >=net-misc/networkmanager-1.2.0:=
21         net-vpn/libreswan
22         gtk? (
23                 app-crypt/libsecret
24                 >=gnome-extra/nm-applet-1.2.0
25                 >=x11-libs/gtk+-3.4:3
26         )
27         !net-misc/networkmanager-openswan
28 "
29 DEPEND="${RDEPEND}
30         sys-devel/gettext
31         dev-util/intltool
32         virtual/pkgconfig
33 "
34
35 src_configure() {
36         local myconf=(
37                 --disable-more-warnings
38                 --disable-static
39                 --with-dist-version=Gentoo
40                 $(use_with gtk gnome)
41         )
42         gnome2_src_configure "${myconf[@]}"
43 }