app-editors/kakoune: drop old 0_pre20160620
[gentoo.git] / net-misc / networkmanager-fortisslvpn / networkmanager-fortisslvpn-1.2.2.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 GNOME_ORG_MODULE="NetworkManager-${PN##*-}"
6
7 inherit gnome2 autotools
8
9 DESCRIPTION="NetworkManager Fortinet SSLVPN compatible plugin"
10 HOMEPAGE="https://wiki.gnome.org/Projects/NetworkManager"
11
12 LICENSE="GPL-2+"
13 SLOT="0"
14 KEYWORDS="~amd64"
15 IUSE="gtk"
16
17 RDEPEND="
18         >=net-misc/networkmanager-1.1:=
19         >=dev-libs/glib-2.32:2
20         net-dialup/ppp:=
21         >=net-vpn/openfortivpn-1.2.0
22         gtk? (
23                 >=app-crypt/libsecret-0.18
24                 >=gnome-extra/nm-applet-1.2.0
25                 >=x11-libs/gtk+-3.4:3
26         )
27 "
28 DEPEND="${RDEPEND}
29         sys-devel/gettext
30         >=dev-util/intltool-0.35
31         virtual/pkgconfig
32 "
33
34 src_prepare() {
35         # Upstream patch 377ba9ca7fb33f3fb2ba5258a5af666869947597
36         eapply "${FILESDIR}/${P}-location-fix.diff"
37
38         eapply_user
39
40         eautoreconf
41
42         gnome2_src_prepare
43 }
44
45 src_configure() {
46         gnome2_src_configure \
47                 --disable-static \
48                 --with-dist-version=Gentoo \
49                 --localstatedir=/var \
50                 $(use_with gtk gnome)
51 }