net-misc/teamviewer: bump version to 13.0.6634
[gentoo.git] / net-misc / netkit-rwho / netkit-rwho-0.17-r4.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit eutils toolchain-funcs
7
8 DESCRIPTION="Netkit - ruptime/rwho/rwhod"
9 HOMEPAGE="http://www.hcs.harvard.edu/~dholland/computers/netkit.html"
10 SRC_URI="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/${P}.tar.gz
11         https://dev.gentoo.org/~jer/${P}-patches.tar.bz2"
12
13 LICENSE="BSD"
14 SLOT="0"
15 KEYWORDS="alpha amd64 arm ~mips ppc s390 sh sparc x86"
16 IUSE=""
17
18 src_prepare() {
19         epatch "${WORKDIR}"/000{1,2,3,4}-*.patch
20         epatch "${FILESDIR}"/${P}-printf.patch #529974
21 }
22
23 src_configure() {
24         # Not an autotools build system
25         ./configure --with-c-compiler=$(tc-getCC) || die
26         sed -i \
27                 -e "s:-O2::" \
28                 -e "s:-Wpointer-arith::" \
29                 MCONFIG || die
30 }
31
32 src_install() {
33         keepdir /var/spool/rwho
34
35         into /usr
36         dobin ruptime/ruptime rwho/rwho
37         dosbin rwhod/rwhod
38
39         doman ruptime/ruptime.1 rwho/rwho.1 rwhod/rwhod.8
40         dodoc README ChangeLog
41
42         newinitd "${FILESDIR}"/${P}-rc rwhod
43         newconfd "${FILESDIR}"/${P}-confd rwhod
44
45         exeinto /etc/cron.monthly
46         doexe "${FILESDIR}"/${P}-cron
47 }