app-editors/kakoune: drop old 0_pre20160620
[gentoo.git] / net-misc / netkit-rusers / netkit-rusers-0.17-r1.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="2"
5
6 inherit eutils toolchain-funcs
7
8 DESCRIPTION="Netkit - rup rpc.rusersd rusers"
9 HOMEPAGE="http://www.hcs.harvard.edu/~dholland/computers/netkit.html"
10 SRC_URI="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/${P}.tar.gz"
11
12 SLOT="0"
13 LICENSE="BSD"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16
17 src_prepare() {
18         epatch "${FILESDIR}"/${P}-include.patch
19         sed -i configure -e '/^LDFLAGS=/d' || die "sed configure"
20 }
21
22 src_configure() {
23         ./configure --with-c-compiler=$(tc-getCC) || die
24         sed -i MCONFIG -e "s:-O2::" -e "s:-Wpointer-arith::" || die "sed MCONFIG"
25 }
26
27 src_compile() {
28         # see bug #244867 for parallel make issues
29         emake -j1 || die
30 }
31
32 src_install() {
33         into /usr
34         dobin rup/rup
35         doman rup/rup.1
36         dobin rpc.rusersd/rusersd
37         doman rpc.rusersd/rpc.rusersd.8
38         dobin rusers/rusers
39         doman rusers/rusers.1
40         dodoc README ChangeLog
41 }