2728a521e68c851fa1d907021729b07fd288b8f2
[gentoo.git] / net-misc / nemesis / nemesis-1.4-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit autotools
6
7 DESCRIPTION="A commandline-based, portable human IP stack for UNIX/Linux"
8 HOMEPAGE="http://nemesis.sourceforge.net/"
9 SRC_URI="mirror://sourceforge/${PN}/${P/_}.tar.gz"
10
11 LICENSE="BSD"
12 SLOT="0"
13 KEYWORDS="~alpha amd64 sparc x86"
14
15 RDEPEND="
16         net-libs/libpcap
17 "
18 DEPEND="
19         ${RDEPEND}
20         =net-libs/libnet-1.0*
21 "
22
23 DOCS="CREDITS ChangeLog README"
24
25 PATCHES=(
26         "${FILESDIR}"/${P}-fileio.patch
27         "${FILESDIR}"/${P}-libnet-1.0.patch
28         "${FILESDIR}"/${P}-prototcp.patch
29 )
30
31 src_prepare() {
32         default
33         eautoreconf
34 }