net-misc/guacamole-server: libvncserver needs threads and jpeg is needed as dep....
[gentoo.git] / net-misc / monmotha / monmotha-2.3.8-r1.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=6
6
7 DESCRIPTION="MonMotha IPTables-based firewall script"
8 HOMEPAGE="http://monmotha.mplug.org/firewall/"
9 LICENSE="GPL-2"
10
11 KEYWORDS="x86 ~amd64"
12 IUSE=""
13 SLOT="0"
14 RDEPEND=">=net-firewall/iptables-1.2.5"
15
16 MY_PVP=(${PV//[-\._]/ })
17
18 S=${WORKDIR}
19
20 SRC_URI="http://monmotha.mplug.org/~monmotha/firewall/firewall/${MY_PVP[0]}.${MY_PVP[1]}/rc.firewall-${PV}"
21
22 src_unpack() {
23         cp "${DISTDIR}"/${A} "${S}"/
24 }
25
26 src_install() {
27         newinitd "${FILESDIR}/monmotha.rc6" monmotha
28         exeinto /etc/monmotha
29         newexe "${S}/rc.firewall-${PV}" monmotha
30 }
31
32 pkg_postinst () {
33         einfo "Don't forget to add the 'monmotha' startup script  to your default"
34         einfo "runlevel by typing the following command:"
35         einfo ""
36         einfo "  rc-update add monmotha default"
37         einfo ""
38         einfo "You need to edit /etc/monmotha/monmotha before using"
39         einfo "it.  Enter the right vars in the file, start the script"
40         einfo "by typing: '/etc/init.d/monmotha start' and it should work."
41         einfo ""
42         einfo "Don't forget to change the path to iptables!!!"
43         einfo ""
44         einfo "Note: If You are stopping the firewall, all iptables rulesets"
45         einfo "will be flushed!!!"
46         einfo ""
47 }