app-editors/kakoune: drop old 0_pre20160620
[gentoo.git] / net-misc / lcr / lcr-9999.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit git-2 autotools
7
8 DESCRIPTION="Linux Call Router"
9 HOMEPAGE="http://isdn.eversberg.eu/"
10 EGIT_REPO_URI="git://git.misdn.eu/lcr.git"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS=""
15 IUSE="asterisk +ssl +gsm-bs +gsm-ms ss5 +sip gsmhr misdn"
16
17 DEPEND="
18         media-libs/opencore-amr
19         asterisk? ( net-misc/asterisk )
20         ssl? ( dev-libs/openssl )
21         gsm-bs? ( net-wireless/openbsc )
22         sip? ( net-libs/sofia-sip )
23         gsm-ms? ( net-wireless/osmocom-bb )
24 "
25         #mdisn? ( net-misc/misdn )
26 RDEPEND="${DEPEND}"
27
28 src_prepare() {
29         sed -i 's:#!/usr/bin/env python:#!/usr/bin/env python2:' "${S}"/libgsmhr/fetch_sources.py
30         eautoreconf
31 }
32
33 src_configure() {
34         CXXFLAGS="$CXXFLAGS -I./include" CFLAGS="$CFLAGS -I./include" econf \
35                 $(use_with asterisk) \
36                 $(use_with ssl) \
37                 $(use_with gsm-bs) \
38                 $(use_with gsm-ms) \
39                 $(use_with ss5) \
40                 $(use_with sip) \
41                 $(use_with misdn) \
42                 $(use_enable gsmhr)
43 }
44
45 src_compile() {
46         emake -j1
47 }
48
49 pkg_postinst() {
50         use gsmhr || return
51         ewarn "You have enabled the gsmhr use flag, for the GSM half-rate"
52         ewarn "codec. This is strongly discouraged, except for testing,"
53         ewarn "because of extremely high CPU usage."
54 }