net-misc/icaclient: use HTTPs
[gentoo.git] / net-misc / kafkacat / kafkacat-1.3.1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="Generic command line non-JVM Apache Kafka producer and consumer"
9 HOMEPAGE="https://github.com/edenhill/kafkacat"
10 SRC_URI="https://github.com/edenhill/kafkacat/archive/${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="BSD-2"
13 SLOT="0"
14 KEYWORDS="~amd64"
15 IUSE="+json"
16
17 DEPEND=">=dev-libs/librdkafka-0.9.4
18         json? ( dev-libs/yajl )"
19 RDEPEND="${DEPEND}"
20
21 src_configure() {
22         econf $(use_enable json) --cc=$(tc-getCC)
23 }
24
25 src_install() {
26         default
27         doman ${PN}.1
28 }