proj/gentoo: Initial commit
[gentoo.git] / net-misc / jwhois / jwhois-4.0.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 DESCRIPTION="Advanced Internet Whois client capable of recursive queries"
6 HOMEPAGE="http://www.gnu.org/software/jwhois/"
7 SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
8
9 LICENSE="GPL-3"
10 SLOT="0"
11 KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ~ppc ppc64 s390 sh sparc x86"
12 IUSE="idn nls"
13
14 DEPEND="idn? ( net-dns/libidn )"
15
16 src_compile() {
17         econf \
18                 --localstatedir=/var/cache \
19                 --without-cache \
20                 $(use_enable nls) \
21                 $(use_with idn libidn) \
22                 || die "econf failed"
23         emake || die
24 }
25
26 src_install() {
27         emake DESTDIR="${D}" install || die
28         dodoc AUTHORS ChangeLog NEWS README TODO
29 }