net-misc/sslh: amd64 stable wrt bug #562754
[gentoo.git] / net-misc / italc / italc-2.0.0.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=4
6
7 inherit qt4-r2 eutils cmake-utils user
8
9 DESCRIPTION="Intelligent Teaching And Learning with Computers (iTALC) supports working with computers in school"
10 HOMEPAGE="http://italc.sourceforge.net/"
11 SRC_URI="mirror://sourceforge/italc/${P}.tar.bz2"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="amd64 x86"
16 IUSE=""
17
18 RDEPEND="
19         dev-libs/lzo
20         dev-libs/openssl
21         sys-apps/tcp-wrappers
22         sys-libs/zlib
23         virtual/jpeg
24         dev-qt/qtcore:4
25         dev-qt/qtxmlpatterns:4
26         x11-libs/libICE
27         x11-libs/libSM
28         x11-libs/libX11
29         x11-libs/libXdamage
30         x11-libs/libXext
31         x11-libs/libXfixes
32         x11-libs/libXrandr
33         x11-libs/libXtst
34         x11-apps/xinput
35         dev-qt/qtgui:4"
36 DEPEND="${RDEPEND}
37         x11-proto/inputproto"
38
39 PROPERTIES="interactive"
40
41 PATCHES=( "${FILESDIR}"/${P}-gcc-4.7.patch )
42
43 DOCS=( TODO README AUTHORS INSTALL ChangeLog )
44
45 pkg_setup() {
46         enewgroup italc
47 }
48
49 pkg_postinst() {
50         elog "On the master, please run "
51         elog "# emerge --config =${CATEGORY}/${PF}"
52
53         elog "Please add the logins of master users (teachers) to the italc group by running"
54         elog "# usermod -a -G italc <loginname>"
55
56         echo ""
57 }
58
59 pkg_config() {
60         if [ ! -d /etc/italc/keys ] ; then
61                 einfo "Creating public and private keys for italc in /etc/italc/keys."
62                 /usr/bin/ica -role teacher -createkeypair > /dev/null
63                 eend $?
64                 einfo "Setting chmod 640 on private keys."
65                 chgrp -R italc /etc/italc
66                 chmod -R o-rwx /etc/italc/keys/private
67         else
68                 einfo "Not creating new keypair, as /etc/italc/keys already exists"
69         fi
70 }