app-editors/kakoune: drop old 0_pre20160620
[gentoo.git] / net-misc / ipsorcery / ipsorcery-2.0.9-r1.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=2
5 inherit toolchain-funcs
6
7 DESCRIPTION="Ipsorcery allows you to generate IP, TCP, UDP, ICMP, and IGMP packets"
8 HOMEPAGE="https://www.gentoo.org/"
9 SRC_URI="mirror://gentoo/ipsorc-${PV}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="amd64 ppc ~sparc x86"
14 IUSE=""
15
16 S=${WORKDIR}/ipsorc-${PV}
17
18 src_prepare() {
19         sed -i \
20                 -e 's:-g -O2:$(LDFLAGS) $(CFLAGS):' \
21                 Makefile || die
22 }
23
24 src_compile() {
25         emake CC="$(tc-getCC)" con || die
26 }
27
28 src_install() {
29         dosbin ipmagic || die
30         dodoc BUGS changelog HOWTO README
31 }