app-editors/kakoune: drop old 0_pre20160620
[gentoo.git] / net-misc / iperf / iperf-3.2.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit autotools eutils
6
7 DESCRIPTION="A TCP, UDP, and SCTP network bandwidth measurement tool"
8 HOMEPAGE="https://github.com/esnet/iperf/"
9 SRC_URI="${HOMEPAGE}archive/${PV/_/}.tar.gz -> ${P}.tar.gz"
10
11 LICENSE="BSD"
12 SLOT="3"
13 KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~m68k-mint"
14 IUSE="sctp static-libs"
15
16 DEPEND="sctp? ( net-misc/lksctp-tools )"
17 RDEPEND="${DEPEND}"
18
19 S=${WORKDIR}/${P/_/}
20
21 PATCHES=( "${FILESDIR}"/${PN}-3.0.5-flags.patch )
22
23 src_prepare() {
24         default
25
26         eautoreconf
27 }
28
29 src_configure() {
30         use sctp || export ac_cv_header_netinet_sctp_h=no
31         econf $(use_enable static-libs static)
32 }
33
34 src_install() {
35         default
36         newconfd "${FILESDIR}"/iperf.confd iperf3
37         newinitd "${FILESDIR}"/iperf3.initd iperf3
38         prune_libtool_files
39 }