app-editors/kakoune: drop old 0_pre20160620
[gentoo.git] / net-misc / iperf / iperf-3.1.3.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit autotools eutils
7
8 DESCRIPTION="A TCP, UDP, and SCTP network bandwidth measurement tool"
9 HOMEPAGE="https://github.com/esnet/iperf/"
10 SRC_URI="https://codeload.github.com/esnet/${PN}/tar.gz/${PV/_beta/b} -> ${P}.tar.gz"
11
12 LICENSE="BSD"
13 SLOT="3"
14 KEYWORDS="amd64 ~arm hppa ~mips ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~m68k-mint"
15 IUSE="sctp static-libs"
16
17 DEPEND="sctp? ( net-misc/lksctp-tools )"
18 RDEPEND="${DEPEND}"
19
20 S=${WORKDIR}/${P/_beta/b}
21
22 PATCHES=( "${FILESDIR}"/${PN}-3.0.5-flags.patch )
23
24 src_prepare() {
25         default
26
27         eautoreconf
28 }
29
30 src_configure() {
31         econf $(use_enable static-libs static)
32 }
33
34 src_install() {
35         default
36         newconfd "${FILESDIR}"/iperf.confd iperf3
37         newinitd "${FILESDIR}"/iperf3.initd iperf3
38         prune_libtool_files
39 }