app-editors/kakoune: drop old 0_pre20160620
[gentoo.git] / net-misc / iperf / iperf-2.0.9.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="Tool to measure IP bandwidth using UDP or TCP"
7 HOMEPAGE="http://iperf2.sourceforge.net/"
8 SRC_URI="mirror://sourceforge/${PN}2/${P}.tar.gz"
9
10 LICENSE="HPND"
11 SLOT="2"
12 KEYWORDS="amd64 ~arm hppa ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~m68k-mint"
13 IUSE="ipv6 threads debug"
14
15 DOCS="INSTALL README"
16
17 src_configure() {
18         econf \
19                 $(use_enable debug debuginfo) \
20                 $(use_enable ipv6) \
21                 $(use_enable threads)
22 }
23
24 src_install() {
25         default
26         dodoc doc/*
27         newinitd "${FILESDIR}"/${PN}.initd-r1 ${PN}
28         newconfd "${FILESDIR}"/${PN}.confd ${PN}
29 }