net-misc/httpie: Bump to version 2.0.0
[gentoo.git] / net-misc / httpie / httpie-2.0.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DISTUTILS_USE_SETUPTOOLS=rdepend
7 PYTHON_COMPAT=( python3_6 python3_7 )
8 PYTHON_REQ_USE="ssl(+)"
9
10 inherit bash-completion-r1 distutils-r1
11
12 DESCRIPTION="Modern command line HTTP client"
13 HOMEPAGE="https://httpie.org/ https://pypi.org/project/httpie/"
14 SRC_URI="https://github.com/jakubroztocil/httpie/archive/${PV}.tar.gz -> ${P}.tar.gz"
15
16 LICENSE="BSD"
17 SLOT="0"
18 KEYWORDS="~amd64 ~x86"
19 IUSE="test"
20 RESTRICT="!test? ( test )"
21
22 RDEPEND="dev-python/pygments[${PYTHON_USEDEP}]
23         >=dev-python/requests-2.22.0[${PYTHON_USEDEP}]"
24 DEPEND="test? (
25                 ${RDEPEND}
26                 dev-python/mock[${PYTHON_USEDEP}]
27                 dev-python/pyopenssl[${PYTHON_USEDEP}]
28                 dev-python/pytest-httpbin[${PYTHON_USEDEP}]
29                 dev-python/pytest[${PYTHON_USEDEP}]
30         )"
31
32 distutils_enable_tests pytest
33
34 python_install_all() {
35         newbashcomp extras/httpie-completion.bash http
36         insinto /usr/share/fish/vendor_completions.d
37         newins extras/httpie-completion.fish http.fish
38         distutils-r1_python_install_all
39 }