net-misc/htpdate: Bump to version 1.1.3
[gentoo.git] / net-misc / htpdate / htpdate-1.1.3.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit readme.gentoo toolchain-funcs unpacker
8
9 DESCRIPTION="Synchronize local workstation with time offered by remote webservers"
10 HOMEPAGE="http://www.vervest.org/fiki/bin/view/HTP/DownloadC"
11 SRC_URI="http://www.vervest.org/htp/archive/c/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~s390 ~sh ~x86 ~amd64-linux ~x86-linux"
16
17 DEPEND=""
18 RDEPEND=""
19
20 DOC_CONTENTS="If you would like to run htpdate as a daemon, set
21 appropriate http servers in /etc/conf.d/htpdate!"
22
23 src_prepare() {
24         # Use more standard adjtimex() to fix uClibc builds.
25         sed -i 's:ntp_adjtime:adjtimex:g' htpdate.[8c] || die
26 }
27
28 src_compile() {
29         emake CFLAGS="-Wall ${CFLAGS} ${LDFLAGS}" CC="$(tc-getCC)"
30 }
31
32 src_install() {
33         dosbin htpdate
34         doman htpdate.8
35         dodoc README Changelog
36
37         newconfd "${FILESDIR}"/htpdate.conf htpdate
38         newinitd "${FILESDIR}"/htpdate.init-r1 htpdate
39
40         readme.gentoo_create_doc
41 }