dev-java/openjdk-jre-bin: bump to 11.0.6_p10
[gentoo.git] / net-misc / hath / hath-0.5.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 # ebuild generated by hackport 0.6
7
8 CABAL_FEATURES="test-suite"
9 inherit haskell-cabal
10
11 DESCRIPTION="Hath manipulates network blocks in CIDR notation"
12 HOMEPAGE="http://michael.orlitzky.com/code/hath.xhtml"
13 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
14
15 LICENSE="AGPL-3"
16 SLOT="0"
17 KEYWORDS="amd64 x86"
18 IUSE=""
19
20 RDEPEND=">=dev-haskell/cmdargs-0.10:=
21         >=dev-haskell/split-0.2:=
22         >=dev-haskell/tasty-0.8:=
23         >=dev-haskell/tasty-hunit-0.8:=
24         >=dev-haskell/tasty-quickcheck-0.8.1:=
25         >=dev-lang/ghc-8.0.1:=
26 "
27 DEPEND="${RDEPEND}
28         >=dev-haskell/cabal-1.24.0.0
29         test? ( dev-util/shelltestrunner )
30 "
31
32 src_install() {
33         cabal_src_install
34         doman "${S}/doc/man1/${PN}.1"
35 }