x11-themes/QGnomePlatform: Drop old
[gentoo.git] / net-misc / haeredes / haeredes-0.5.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 CABAL_FEATURES="bin test-suite"
7 inherit haskell-cabal
8
9 DESCRIPTION="Confirm delegation of NS and MX records"
10 HOMEPAGE="http://michael.orlitzky.com/code/haeredes.xhtml"
11 SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
12
13 LICENSE="AGPL-3"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 # The test suite requires network access.
19 RESTRICT="test"
20
21 RDEPEND=">=dev-haskell/cmdargs-0.10:=
22         >=dev-haskell/dns-1.4:=
23         >=dev-haskell/iproute-1.2:=
24         >=dev-haskell/parallel-io-0.3:=
25         >=dev-lang/ghc-7.6.1:=
26 "
27 DEPEND="${RDEPEND}
28         >=dev-haskell/cabal-1.16.0
29         test? ( >=dev-haskell/doctest-0.9
30                 >=dev-haskell/filemanip-0.3.6
31                 dev-util/shelltestrunner )
32 "
33
34 src_install() {
35         haskell-cabal_src_install
36         doman "${S}/doc/man1/${PN}.1"
37 }