app-editors/kakoune: drop old 0_pre20160620
[gentoo.git] / net-misc / grive / grive-0.4.0_pre20151011.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit cmake-utils
7
8 if [[ ${PV} = *9999 ]]; then
9         inherit git-2
10         EGIT_REPO_URI="https://github.com/vitalif/${PN}2.git"
11 else
12         inherit vcs-snapshot
13         COMMIT="44cb91f94e67bcdad77ca564b4d8083cedf72251"
14         SRC_URI="https://github.com/vitalif/${PN}2/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
15 fi
16
17 DESCRIPTION="An open source Linux client for Google Drive"
18 HOMEPAGE="https://github.com/vitalif/grive2"
19
20 LICENSE="GPL-2"
21 SLOT="0"
22 KEYWORDS="~amd64 ~x86"
23 IUSE=""
24
25 RDEPEND="
26         dev-libs/boost:=
27         dev-libs/expat
28         >=dev-libs/json-c-0.11-r1:=
29         dev-libs/libgcrypt:0=
30         net-misc/curl
31         sys-libs/binutils-libs:0=
32         sys-libs/glibc
33         dev-libs/yajl
34 "
35 DEPEND="${RDEPEND}"