dev-perl/Tk-JPEG-Lite: stable 2.15.0 for sparc, bug #667266
[gentoo.git] / net-misc / getdate / getdate-1.2-r1.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=4
5
6 MY_PN="${PN}_rfc868"
7 MY_P="${MY_PN}-${PV}"
8
9 inherit toolchain-funcs
10
11 DESCRIPTION="Network Date/Time Query and Set Local Date/Time Utility"
12 HOMEPAGE="http://www.ibiblio.org/pub/Linux/system/network/misc/"
13 SRC_URI="http://www.ibiblio.org/pub/Linux/system/network/misc/${MY_P}.tar.gz"
14
15 LICENSE="GPL-1+"
16 SLOT="0"
17 KEYWORDS="amd64 ~mips ppc x86"
18 IUSE=""
19
20 S="${WORKDIR}/${MY_P}"
21
22 src_prepare() {
23         sed -i -e "/errno.h/ a\#include <string.h>" getdate.c || die
24         # Respect CFLAGS
25         sed -i -e "/CFLAGS/d" Makefile || die
26 }
27
28 src_compile() {
29         emake CC="$(tc-getCC)"
30 }
31
32 src_install() {
33         dobin getdate
34         doman getdate.8
35         dodoc README getdate-cron
36 }