app-editors/kakoune: drop old 0_pre20160620
[gentoo.git] / net-misc / ethercard-diag / ethercard-diag-20050321.1g-r1.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="6"
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="low level mii diagnostic tools including mii-diag and etherwake (merge of netdiag/isa-diag)"
9 HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
10 SRC_URI="mirror://gentoo/${P}.tar.lzma"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16
17 RDEPEND="!sys-apps/nictools"
18
19 src_prepare() {
20         default
21         # Since the binary is `ether-wake`, make sure the man page is
22         # `man ether-wake` and not `man etherwake`. #439504
23         sed -i \
24                 -e 's/ETHERWAKE/ETHER-WAKE/' \
25                 -e 's/etherwake/ether-wake/' \
26                 pub/diag/{etherwake.8,Makefile} patches/* || die
27         mv pub/diag/ether{,-}wake.8 || die
28 }
29
30 src_compile() {
31         tc-export CC AR
32         default
33 }