dev-python/repoze-lru: keyworded 0.7-r1 for ia64, bug #717946
[gentoo.git] / net-misc / efax / efax-0.9a_p19_p1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 inherit toolchain-funcs
6
7 DESCRIPTION="A simple fax program for single-user systems"
8 HOMEPAGE="http://www.cce.com/efax"
9 SRC_URI="
10         mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV/_p*}.orig.tar.gz
11         mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV/_p*}-$(ver_cut 5).$(ver_cut 7).diff.gz
12 "
13
14 KEYWORDS="~amd64 ~ppc ~x86"
15 SLOT="0"
16 LICENSE="GPL-2"
17 PATCHES=(
18         "${FILESDIR}"/${PN}-0.9a-fax-command.patch
19         "${FILESDIR}"/${PN}-0.9a-fno-common.patch
20         "${FILESDIR}"/${PN}-0.9a-strip.patch
21 )
22 S="${WORKDIR}/${P/_p*}-001114"
23
24 src_prepare() {
25         eapply "${WORKDIR}"/${PN}_${PV/_p*}-$(ver_cut 5).$(ver_cut 7).diff
26         local patch
27         for patch in $(< debian/patches/00list); do
28                 if [[ -f debian/patches/${patch} ]]; then
29                         eapply debian/patches/${patch}
30                 elif [[ -f debian/patches/${patch}.dpatch ]]; then
31                         eapply debian/patches/${patch}.dpatch
32                 else
33                         die "Cannot find patch ${patch}"
34                 fi
35         done
36
37         default
38 }
39
40 src_compile() {
41         emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
42 }
43
44 src_install() {
45         dobin efax efix fax
46         doman efax.1 efix.1
47         newman fax.1 efax-fax.1 # Don't collide with net-dialup/mgetty, bug #429808
48         dodoc README
49 }