net-misc/sslh: amd64 stable wrt bug #562754
[gentoo.git] / net-misc / dibbler / dibbler-0.8.4.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6 inherit eutils readme.gentoo systemd
7
8 DESCRIPTION="Portable DHCPv6 implementation (server, client and relay)"
9 HOMEPAGE="http://klub.com.pl/dhcpv6/"
10 SRC_URI="http://klub.com.pl/dhcpv6/dibbler/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 hppa ~mips x86"
15 IUSE="doc"
16
17 DEPEND="doc? ( || (
18                 dev-texlive/texlive-latexextra
19                 dev-tex/floatflt )
20         )"
21 RDEPEND=""
22
23 DOC_CONTENTS="Make sure that you modify client.conf, server.conf and/or relay.conf
24 to suit your needs. They are stored in /etc/dibbler"
25
26 src_prepare() {
27         epatch_user
28 }
29
30 src_compile() {
31         emake
32         # devel documentation is broken and users should consult the online version
33         # http://klub.com.pl/dhcpv6/doxygen/
34         use doc && emake -C doc/ user
35 }
36
37 src_install() {
38         readme.gentoo_create_doc
39
40         dosbin dibbler-{client,relay,server}
41         doman doc/man/*.8
42
43         insinto /etc/dibbler
44         doins doc/examples/*.conf
45         dodir /var/lib/dibbler
46
47         dodoc AUTHORS CHANGELOG RELNOTES TODO
48         use doc && dodoc doc/dibbler-user.pdf
49
50         doinitd "${FILESDIR}"/dibbler-{client,relay,server}
51         systemd_dounit "${FILESDIR}"/dibbler-client.service
52 }