net-misc/youtube-dl: Version 2019.03.09
[gentoo.git] / net-misc / dahdi-tools / dahdi-tools-2.9.0.1.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit base
7
8 DESCRIPTION="Userspace tools to configure the kernel modules from net-misc/dahdi"
9 HOMEPAGE="http://www.asterisk.org"
10 SRC_URI="http://downloads.asterisk.org/pub/telephony/${PN}/releases/${P}.tar.gz
11         mirror://gentoo/gentoo-${PN}-patchset-0.4.tar.bz2"
12
13 LICENSE="LGPL-2.1"
14 SLOT="0"
15 KEYWORDS="amd64 x86"
16 IUSE="ppp"
17
18 DEPEND="dev-libs/newt
19         ppp? ( net-dialup/ppp )
20         >=net-misc/dahdi-2.5.0
21         !net-misc/zaptel
22         >=sys-kernel/linux-headers-2.6.35
23         virtual/libusb:0"
24 RDEPEND="${DEPEND}"
25
26 EPATCH_SUFFIX="diff"
27 PATCHES=( "${WORKDIR}/${PN}-patchset" )
28
29 src_compile() {
30         default_src_compile
31         emake tests
32         use ppp && emake -C ppp
33 }
34
35 src_install() {
36         emake DESTDIR="${D}" install
37         use ppp && emake DESTDIR="${D}" -C ppp install
38         emake DESTDIR="${D}" config
39
40         dosbin patgen pattest patlooptest hdlcstress hdlctest hdlcgen hdlcverify timertest
41
42         # install init scripts
43         newinitd "${FILESDIR}"/dahdi.init2 dahdi
44         newinitd "${FILESDIR}"/dahdi-autoconf.init2 dahdi-autoconf
45         newconfd "${FILESDIR}"/dahdi-autoconf.conf2 dahdi-autoconf
46 }