app-editors/kakoune: drop old 0_pre20160620
[gentoo.git] / net-misc / batctl / batctl-2014.2.0.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=4
5
6 inherit linux-info toolchain-funcs
7
8 DESCRIPTION="BATMAN advanced control and management tool"
9 HOMEPAGE="http://www.open-mesh.org/"
10 SRC_URI="http://downloads.open-mesh.org/batman/stable/sources/${PN}/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16
17 RDEPEND="dev-libs/libnl:3"
18 DEPEND="${RDEPEND}
19         virtual/pkgconfig"
20
21 pkg_setup() {
22         if ( linux_config_exists && linux_chkconfig_present BATMAN_ADV ) \
23                 || ! has_version net-misc/batman-adv ; then
24                 ewarn "You need the batman-adv kernel module,"
25                 ewarn "either from the kernel tree or via net-misc/batman-adv"
26         fi
27 }
28
29 src_compile() {
30         emake CC="$(tc-getCC)" V=1 REVISION=gentoo-"${PVR}"
31 }
32
33 src_install() {
34         emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
35         dodoc README
36 }