dev-python/csv23: arm64 keyworded (bug #719700)
[gentoo.git] / net-misc / arpd / arpd-0.2-r1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit autotools
7
8 DESCRIPTION="ARP server claiming all unassigned addresses (for network monitoring/simulation)"
9 HOMEPAGE="http://www.citi.umich.edu/u/provos/honeyd/"
10 SRC_URI="http://www.citi.umich.edu/u/provos/honeyd/${P}.tar.gz"
11
12 LICENSE="BSD"
13 SLOT="0"
14 KEYWORDS="amd64 hppa ppc ~ppc64 sparc x86"
15 IUSE=""
16
17 DEPEND="
18         >=dev-libs/libdnet-1.4
19         >=dev-libs/libevent-0.6
20         net-libs/libpcap
21         !sys-apps/iproute2"
22 RDEPEND="${DEPEND}"
23
24 S=${WORKDIR}/${PN}
25
26 PATCHES=(
27         "${FILESDIR}"/arpd.c.patch
28         "${FILESDIR}"/${P}-libevent.patch
29
30         # bug 337481, replace test on libevent.a with libevent.so
31         "${FILESDIR}"/${P}-buildsystem-libevent-test.patch
32 )
33
34 src_prepare() {
35         default
36         mv configure.{in,ac} || die
37         eautoreconf
38 }
39
40 src_configure() {
41         econf \
42                 --with-libdnet="${EPREFIX}"/usr \
43                 --with-libevent="${EPREFIX}"/usr
44 }
45
46 src_install() {
47         dosbin arpd
48         doman arpd.8
49 }