net-mail/automx2: amd64 stable wrt bug #721532
[gentoo.git] / net-mail / swaks / swaks-20190914.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DESCRIPTION="Swiss Army Knife SMTP; Command line SMTP testing, including TLS and AUTH"
7 HOMEPAGE="https://www.jetmore.org/john/code/swaks"
8 SRC_URI="https://www.jetmore.org/john/code/swaks/${P}.tar.gz"
9 LICENSE="GPL-2"
10 SLOT="0"
11 KEYWORDS="~amd64 ~ppc ~x86"
12
13 IUSE="ssl"
14
15 DEPEND=">=dev-lang/perl-5.8.8"
16
17 RDEPEND="${DEPEND}
18                 >=dev-perl/Net-DNS-0.65
19                 ssl? ( >=dev-perl/Net-SSLeay-1.35 )
20                 >=virtual/perl-MIME-Base64-3.07
21                 >=virtual/perl-Digest-MD5-2.39
22                 >=virtual/perl-Time-HiRes-1.97
23                 >=virtual/perl-Time-Local-1.19
24                 >=dev-perl/Authen-NTLM-1.02
25                 >=dev-perl/Authen-DigestMD5-0.04
26                 virtual/perl-Digest-SHA"
27
28 src_compile() {
29         /usr/bin/pod2man -s 1 doc/ref.pod swaks.1 || die "man page compulation failed"
30 }
31
32 src_install() {
33         dobin swaks
34         doman swaks.1
35         dodoc README.txt doc/*.txt
36 }