net-mail/courier-imap: Not calling ar directly
[gentoo.git] / net-mail / swaks / swaks-20130209.0-r1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit eutils
6
7 DESCRIPTION="Swiss Army Knife SMTP; Command line SMTP testing, including TLS and AUTH"
8 HOMEPAGE="http://www.jetmore.org/john/code/swaks"
9 SRC_URI="http://www.jetmore.org/john/code/swaks/${P}.tar.gz"
10 LICENSE="GPL-2"
11 SLOT="0"
12 KEYWORDS="amd64 ~ppc x86"
13
14 IUSE="ssl"
15
16 DEPEND=">=dev-lang/perl-5.8.8"
17
18 RDEPEND="${DEPEND}
19                 >=dev-perl/Net-DNS-0.65
20                 ssl? ( >=dev-perl/Net-SSLeay-1.35 )
21                 >=virtual/perl-MIME-Base64-3.07
22                 >=virtual/perl-Digest-MD5-2.39
23                 >=virtual/perl-Time-HiRes-1.97
24                 >=virtual/perl-Time-Local-1.19
25                 >=dev-perl/Authen-NTLM-1.02
26                 >=dev-perl/Authen-DigestMD5-0.04
27                 virtual/perl-Digest-SHA"
28
29 src_prepare() {
30         epatch "${FILESDIR}"/${PN}-perl-5.18.patch
31 }
32
33 src_compile() {
34         /usr/bin/pod2man -s 1 doc/ref.pod swaks.1 || die "man page compulation failed"
35 }
36
37 src_install() {
38         newbin swaks swaks
39         doman swaks.1
40         dodoc README doc/*.txt
41 }