Merge remote-tracking branch 'origin/dev-python/django-cache-url'
[wtk-overlay.git] / net-mail / rss2email / rss2email-9999.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="4"
6
7 PYTHON_DEPEND="3:3.2"
8 SUPPORT_PYTHON_ABIS="1"
9 RESTRICT_PYTHON_ABIS="2.* 3.[01]"
10
11 inherit eutils distutils
12
13 if [[ "${PV}" == "9999" ]] ; then
14         inherit git-2
15         EGIT_BRANCH="master"
16         EGIT_REPO_URI="git://github.com/wking/${PN}.git"
17         SRC_URI=""
18 else
19         SRC_URI="https://github.com/wking/${PN}/tarball/v${PV} -> ${P}.tar.gz"
20 fi
21
22 DESCRIPTION="A python script that converts RSS/Atom newsfeeds to email"
23 HOMEPAGE="https://github.com/wking/rss2email/"
24
25 LICENSE="GPL-2"
26 SLOT="0"
27 KEYWORDS="~amd64 ~x86"
28 IUSE=""
29
30 RDEPEND=">=dev-python/feedparser-5.0.1
31         >=dev-python/html2text-3.01"
32
33 src_install() {
34         distutils_src_install
35         dodoc CHANGELOG README
36         doman r2e.1
37 }