net-mail/notmuch: add ~ppc64 keyword
[gentoo.git] / net-mail / queue-fix / queue-fix-1.4-r3.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit fixheadtails toolchain-funcs
7
8 DESCRIPTION="Qmail Queue Repair Application with support for big-todo"
9 HOMEPAGE="http://www.netmeridian.com/e-huss/"
10 SRC_URI="http://www.netmeridian.com/e-huss/${P}.tar.gz
11         mirror://qmail/queue-fix-todo.patch"
12
13 LICENSE="all-rights-reserved public-domain" # includes code from qmail
14 SLOT="0"
15 KEYWORDS="~alpha amd64 arm hppa ~ia64 ~m68k ~mips ppc s390 sparc x86"
16 RESTRICT="mirror bindist"
17
18 PDEPEND="virtual/qmail"
19
20 PATCHES=(
21         "${DISTDIR}"/queue-fix-todo.patch
22         "${FILESDIR}"/${P}-stdlib.patch
23         "${FILESDIR}"/${P}-errno.patch
24 )
25
26 src_unpack() {
27         default
28         ht_fix_file "${S}"/Makefile*
29 }
30
31 src_configure() {
32         echo "$(tc-getCC) ${CFLAGS}" > conf-cc
33         echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
34         sed -e "s#'ar #'$(tc-getAR) #" -e "s#'ranlib #'$(tc-getRANLIB) #" -i make-makelib.sh || die
35 }
36
37 src_install() {
38         dobin queue-fix
39
40         einstalldocs
41 }