net-mail/dovecot: drop to ~hppa
[gentoo.git] / net-mail / qtools / qtools-0.56.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="Utilities for use with qmail, typically as part of .qmail command processing"
9 HOMEPAGE="http://www.superscript.com/qtools/intro.html"
10 SRC_URI="http://www.superscript.com/qtools/${P}.tar.gz"
11
12 LICENSE="all-rights-reserved public-domain" # includes code from qmail
13 SLOT="0"
14 KEYWORDS="~alpha ~amd64 ~hppa ~mips ppc ~sparc x86"
15 IUSE="static"
16 RESTRICT="mirror bindist"
17
18 PATCHES=(
19         "${FILESDIR}"/${P}-errno.patch
20         "${FILESDIR}"/${P}-head.patch
21 )
22
23 src_configure() {
24         use static && LDFLAGS="${LDFLAGS} -static"
25         export CC="$(tc-getCC)"
26         echo "${CC} ${CFLAGS}" > conf-cc || die
27         echo "${CC} ${LDFLAGS}" > conf-ld || die
28         echo "/usr" > conf-home || die
29 }
30
31 src_install() {
32         dobin 822addr 822body 822bodyfilter 822fields 822headerfilter \
33                 822headerok 822headers checkaddr checkdomain \
34                 condtomaildir filterto ifaddr iftoccfrom replier \
35                 replier-config tomaildir
36
37         dodoc BAPVERSION CHANGES FILES README SYSDEPS TARGETS TODO VERSION
38 }