Merge media-sound/spotify: Fix homepage URL
[gentoo.git] / net-mail / qmrtg / qmrtg-2.1-r1.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 inherit eutils
7
8 DESCRIPTION="A tool to analyze qmail activity with the goal to graph everything through MRTG"
9 HOMEPAGE="http://dev.publicshout.org/qmrtg"
10 SRC_URI="${HOMEPAGE}/download/${P}.tar.gz"
11
12 LICENSE="BSD"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="doc"
16
17 RDEPEND="net-analyzer/mrtg"
18
19 src_prepare() {
20         sed -i \
21                 -e 's|^CFLAGS =|CFLAGS ?=|g' \
22                 analyzers/Makefile.in filters/Makefile.in || die
23
24         epatch "${FILESDIR}"/mrtg.cfg.patch
25         epatch "${FILESDIR}"/qmrtg.conf.sample.patch
26         epatch "${FILESDIR}"/${P}-TAI_STR_LEN.patch
27 }
28
29 DOCS=( INSTALL.txt )
30
31 src_install () {
32         default
33         keepdir /var/lib/qmrtg
34         if use doc ; then
35                 docinto txt
36                 dodoc doc/*.txt
37                 docinto html
38                 dohtml -r html/*
39         fi
40
41         insinto /usr/share/qmrtg2
42         doins examples/*
43
44 }
45
46 pkg_postinst () {
47         elog
48         elog "You need to configure manually qmrtg in order to run it."
49         elog "The configuration templates in /usr/share/qmrtg2/ and"
50         elog "the INSTALL file in /usr/share/doc/qmrtg-2.1/"
51         elog "will be useful."
52         elog
53 }