net-mail/courier-imap-4.16.2-r1: stable on amd64
[gentoo.git] / net-mail / qmail-qfilter / qmail-qfilter-2.1-r1.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="2"
6
7 inherit toolchain-funcs multilib
8
9 DESCRIPTION="qmail-queue multi-filter front end"
10 SRC_URI="http://untroubled.org/qmail-qfilter/archive/${P}.tar.gz"
11 HOMEPAGE="http://untroubled.org/qmail-qfilter/"
12
13 SLOT="0"
14 LICENSE="GPL-2"
15 KEYWORDS="~amd64 ~ppc ~sparc ~x86"
16 IUSE=""
17
18 DEPEND=">=dev-libs/bglibs-1.106"
19 RDEPEND="${DEPEND} virtual/qmail"
20
21 QMAIL_BINDIR="/var/qmail/bin/"
22
23 src_configure() {
24         echo "$(tc-getCC) ${CFLAGS}" > conf-cc
25         echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
26         echo "${D}${QMAIL_BINDIR}" > conf-bin
27         echo "${D}/usr/share/man/" > conf-man
28         echo "/usr/include/bglibs" > conf-bgincs
29         echo "/usr/$(get_libdir)/bglibs" > conf-bglibs
30 }
31
32 src_install () {
33         dodir ${QMAIL_BINDIR} /usr/share/man/
34         emake install || die "Installer failed"
35         dodoc ANNOUNCEMENT NEWS README TODO
36         docinto samples
37         dodoc samples/*
38 }
39
40 pkg_postinst() {
41         elog "Please see /usr/share/doc/${PF}/README* for configuration information"
42 }