net-mail/dovecot: security bump to 2.3.10.1
[gentoo.git] / net-mail / qmail-autoresponder / qmail-autoresponder-2.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="Rate-limited autoresponder for qmail"
9 HOMEPAGE="https://untroubled.org/qmail-autoresponder/"
10 SRC_URI="https://untroubled.org/qmail-autoresponder/archive/${P}.tar.gz"
11
12 SLOT="0"
13 LICENSE="GPL-2+"
14 KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
15 IUSE="mysql"
16
17 DEPEND=">=dev-libs/bglibs-2.04
18         mysql? ( dev-db/mysql-connector-c:0= )"
19 RDEPEND="${DEPEND}
20         virtual/qmail
21         mysql? ( virtual/mysql )"
22
23 src_configure() {
24         echo "$(tc-getCC) ${CFLAGS}" > conf-cc || die
25         echo "$(tc-getCC) ${LDFLAGS}" > conf-ld || die
26 }
27
28 src_compile() {
29         emake qmail-autoresponder
30         if use mysql; then
31                 emake qmail-autoresponder-mysql
32         fi
33 }
34
35 src_install() {
36         dobin qmail-autoresponder
37         doman qmail-autoresponder.1
38         if use mysql; then
39                 dobin qmail-autoresponder-mysql
40                 doman qmail-autoresponder-mysql.1
41                 dodoc schema.mysql
42         fi
43
44         dodoc ANNOUNCEMENT NEWS README TODO ChangeLog procedure.txt
45 }