net-mail/automx: Remove last-rited pkg
[gentoo.git] / net-mail / qlogtools / qlogtools-3.1-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit eutils toolchain-funcs
7
8 DESCRIPTION="Qmail Log processing tools"
9 HOMEPAGE="http://untroubled.org/qlogtools/"
10 SRC_URI="http://untroubled.org/qlogtools/archive/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~ppc ~sparc ~x86"
15 IUSE=""
16
17 DEPEND=""
18 RDEPEND="!app-text/multitail"
19
20 PATCHES=(
21         "${FILESDIR}"/qlogtools-3.1-errno.patch
22 )
23
24 src_configure() {
25         echo "$(tc-getCC) ${CFLAGS}" > conf-cc
26         echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
27         echo "${D}/usr/bin" > conf-bin
28         echo "${D}/usr/share/man/" > conf-man
29 }
30
31 src_install() {
32         dodir /usr/bin /usr/share/man/
33         ./installer || die "Installer failed"
34         dodoc ANNOUNCEMENT FILES NEWS README TARGETS VERSION
35 }
36
37 pkg_postinst() {
38         elog "Please see /usr/share/doc/${PF}/README for configuration information"
39 }