net-mail/notmuch: Fix error on configure with 'crypt' flag disabled
[gentoo.git] / net-mail / poppassd_ceti / poppassd_ceti-1.8.7.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit pam readme.gentoo-r1
7
8 # Long ago it was just "poppassd", but upstream now seems to have
9 # settled on "poppassd-ceti" (instead of "poppassd_ceti" or no suffix).
10 MY_PN="poppassd-ceti"
11 MY_P="${MY_PN}-${PV}"
12 S=${WORKDIR}/${MY_P}
13
14 DESCRIPTION="Password change daemon with PAM support"
15 HOMEPAGE="https://github.com/kravietz/poppassd-ceti"
16 SRC_URI="https://github.com/kravietz/${MY_PN}/releases/download/v${PV}/${MY_P}.tar.xz"
17
18 # Strictly speaking the "or later version" clarification was only
19 # added upstream after 1.8.7:
20 LICENSE="GPL-2+"
21 SLOT="0"
22 KEYWORDS="amd64 x86"
23
24 DEPEND="sys-libs/pam"
25 RDEPEND="${DEPEND}"
26
27 FORCE_PRINT_ELOG=1  # possibly remove in the next bump
28 DISABLE_AUTOFORMATTING=1
29 DOC_CONTENTS="poppassd is installed, but has to be run as root to work.
30
31 Most commonly a front end would require sys-apps/xinetd and connect to
32 port 106: For this, edit /etc/xinetd.d/poppassd, install sys-apps/xinetd,
33 and start the xinetd service.
34
35 Alternatively, a front end may be able to run it directly (if already
36 root), or might use app-admin/sudo.  To use sudo, you'll need to configure
37 /etc/sudoers with something similar to:
38
39     apache ALL=(ALL)       NOPASSWD: /usr/sbin/poppassd
40
41 See also README.md.bz2 for related configuration and security
42 considerations.
43 "
44
45 src_install() {
46         dodoc README.md
47         readme.gentoo_create_doc
48
49         pamd_mimic_system poppassd auth account password
50
51         insinto /etc/xinetd.d
52         newins "${FILESDIR}"/poppassd.xinetd poppassd
53
54         exeinto /usr/sbin
55         exeopts -o root -g bin -m 500
56         doexe poppassd
57 }
58
59 pkg_postinst() {
60         readme.gentoo_print_elog
61 }