net-mail/cyrus-imapd: amd64 stable wrt bug #703630
[gentoo.git] / net-mail / mswatch / mswatch-1.2.0-r1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit linux-info ltprune
6
7 DESCRIPTION="A utility to watch mailstores for changes and initiate mailbox syncs"
8 HOMEPAGE="http://mswatch.sourceforge.net/"
9 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="static-libs"
15
16 RDEPEND=">=dev-libs/glib-2.6:2"
17 DEPEND="${RDEPEND}
18         virtual/pkgconfig
19 "
20
21 CONFIG_CHECK="~INOTIFY_USER"
22 ERROR_INOTIFY_USER="${P} requires in-kernel inotify support."
23
24 PATCHES=(
25         "${FILESDIR}"/${P}-gcc47.patch
26         "${FILESDIR}"/${P}-gcc6.patch
27 )
28
29 src_configure() {
30         econf \
31                 --with-notify=inotify \
32                 --enable-shared \
33                 $(use_enable static-libs static)
34 }
35
36 src_install() {
37         default
38         prune_libtool_files
39 }