net-mail/tnef: ppc stable wrt bug #701816
[gentoo.git] / net-mail / mlmmj / mlmmj-1.3.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 MY_PV="${PV/_rc/-RC}"
7 MY_P="${PN}-${MY_PV}"
8 DESCRIPTION="Mailing list managing made joyful"
9 HOMEPAGE="http://mlmmj.org/"
10 SRC_URI="http://mlmmj.org/releases/${MY_P}.tar.bz2"
11 LICENSE="MIT"
12 SLOT="0"
13 KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
14 IUSE=""
15 DEPEND="virtual/mta"
16 S="${WORKDIR}/${MY_P}"
17
18 DOCS="AUTHORS ChangeLog FAQ README* TODO TUNABLES UPGRADE"
19 PATCHES=(
20         "${FILESDIR}"/mlmmj-1.2.19.0-listcontrol-customheaders.patch
21         "${FILESDIR}"/mlmmj-1.3.0-gcc-10.patch
22 )
23
24 src_configure() {
25         econf --enable-receive-strip
26 }
27
28 src_install() {
29         default
30
31         insinto /usr/share/mlmmj/texts
32         doins listtexts/*
33
34         insinto /usr/share/mlmmj
35         doins -r contrib/web/*
36 }
37
38 pkg_postinst() {
39         elog "mlmmj comes with serveral webinterfaces:"
40         elog "- One for user subscribing/unsubscribing"
41         elog "- One for admin tasks"
42         elog "both available in a php and perl module."
43         elog "For more info have a look in /usr/share/mlmmj"
44 }