net-mail/b4: bump to 0.3.7
[gentoo.git] / net-mail / mlmmj / mlmmj-1.2.19.0-r1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 MY_PV="${PV/_rc/-RC}"
7 MY_P="${PN}-${MY_PV}"
8 DESCRIPTION="Mailing list managing made joyful"
9 HOMEPAGE="http://mlmmj.org/"
10 SRC_URI="http://mlmmj.org/releases/${MY_P}.tar.bz2"
11 LICENSE="MIT"
12 SLOT="0"
13 KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
14 IUSE=""
15 DEPEND="virtual/mta"
16 S="${WORKDIR}/${MY_P}"
17
18 DOCS="AUTHORS ChangeLog FAQ README* TODO TUNABLES UPGRADE"
19 PATCHES=(
20         "${FILESDIR}"/mlmmj-1.2.19.0-listcontrol-customheaders.patch
21 )
22
23 src_configure() {
24         econf --enable-receive-strip
25 }
26
27 src_install() {
28         default
29
30         insinto /usr/share/mlmmj/texts
31         doins listtexts/*
32
33         insinto /usr/share/mlmmj
34         doins -r contrib/web/*
35 }
36
37 pkg_postinst() {
38         elog "mlmmj comes with serveral webinterfaces:"
39         elog "- One for user subscribing/unsubscribing"
40         elog "- One for admin tasks"
41         elog "both available in a php and perl module."
42         elog "For more info have a look in /usr/share/mlmmj"
43 }