Unify quoting in metadata.xml files for machine processing
[gentoo.git] / net-mail / mhonarc / mhonarc-2.6.18-r2.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit perl-module
8
9 DESCRIPTION="Perl Mail-to-HTML Converter"
10 HOMEPAGE="http://www.mhonarc.org/"
11 SRC_URI="http://www.mhonarc.org/release/MHonArc/tar/MHonArc-${PV}.tar.bz2"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="amd64 ~mips ~ppc x86"
16 # Warrants IUSE examples, and here it is + ? IUSE doc; see also extras folder with html docs
17 IUSE="examples"
18
19 RESTRICT="mirror"
20
21 S="${WORKDIR}/${P/mhonarc/MHonArc}"
22 mydoc="README.txt"
23
24 src_install() {
25         sed -e "s|-prefix |-docpath '${D}/usr/share/doc/${PF}/html' -prefix '${D}'|g" -i Makefile || die 'sed on Makefile failed'
26         sed -e "s|installsitelib|installvendorlib|g" -i install.me || die 'sed on install.me failed'
27         perl-module_src_install
28         if use examples; then
29                 docompress -x usr/share/doc/${PF}/examples
30                 insinto usr/share/doc/${PF}/
31                 doins -r examples/
32         fi
33 }