net-mail/notmuch: add ~ppc64 keyword
[gentoo.git] / net-mail / mboxgrep / mboxgrep-0.7.9-r2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DESCRIPTION="Grep for mbox files"
7 SRC_URI="mirror://sourceforge/mboxgrep/${P}.tar.gz"
8 HOMEPAGE="https://datatipp.se/mboxgrep/"
9
10 SLOT="0"
11 LICENSE="GPL-2+"
12 KEYWORDS="~amd64 ~ppc ~x86"
13 IUSE="dmalloc"
14
15 RDEPEND="
16         app-arch/bzip2
17         dev-libs/libpcre
18         sys-libs/zlib
19         dmalloc? ( dev-libs/dmalloc )
20 "
21 DEPEND="
22         ${RDEPEND}
23 "
24 PATCHES=(
25         "${FILESDIR}"/${P}-_DEFAULT_SOURCE.patch
26         "${FILESDIR}"/${P}-fno-common.patch
27         "${FILESDIR}"/${P}-ldflags.patch
28 )
29
30 src_configure() {
31         econf \
32                 $(use_with dmalloc no yes)
33 }
34
35 src_install() {
36         emake \
37                 prefix="${D}"/usr \
38                 mandir="${D}"/usr/share/man \
39                 infodir="${D}"/usr/share/info \
40                 install
41         dodoc ChangeLog NEWS TODO README
42 }