app-editors/kakoune: drop old 0_pre20160620
[gentoo.git] / net-mail / mairix / mairix-0.23.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=4
5
6 inherit toolchain-funcs eutils
7
8 DESCRIPTION="Indexes and searches Maildir/MH folders"
9 HOMEPAGE="http://www.rpcurnow.force9.co.uk/mairix/"
10 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
11         gnus? ( mirror://gentoo/${P}-gnus-marks-propagation.patch.gz )"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="amd64 ppc x86 ~x86-macos"
16
17 IUSE="zlib bzip2 gnus"
18
19 RDEPEND="zlib? ( sys-libs/zlib )
20         bzip2? ( app-arch/bzip2 )"
21
22 DEPEND="${RDEPEND}
23         sys-devel/flex
24         sys-devel/bison"
25
26 # Fail on various locales
27 RESTRICT="test"
28
29 src_prepare() {
30         # econf would fail with unknown options.
31         # Now it only prints "Unrecognized option".
32         sed -i -e "/^[[:space:]]*bad_options=yes/d" "${S}"/configure || die "sed failed"
33
34         # Add support for gnus marks propagation (bug #274578)
35         use gnus && epatch "${WORKDIR}"/${P}-gnus-marks-propagation.patch
36 }
37
38 src_configure() {
39         tc-export CC
40         econf \
41                 $(use_enable zlib gzip-mbox) \
42                 $(use_enable bzip2 bzip-mbox)
43 }
44
45 src_install() {
46         dobin mairix
47         doman mairix.1 mairixrc.5
48         dodoc NEWS README dotmairixrc.eg
49 }