net-mail/dovecot: drop to ~hppa
[gentoo.git] / net-mail / mailbox-count / mailbox-count-0.0.5.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 CABAL_FEATURES="test-suite"
7 inherit haskell-cabal
8
9 DESCRIPTION="Count mailboxes in a SQL database"
10 HOMEPAGE="http://hackage.haskell.org/package/mailbox-count"
11 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
12
13 LICENSE="AGPL-3"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 RDEPEND="
19         >=dev-haskell/cmdargs-0.10
20         >=dev-haskell/configurator-0.2
21         >=dev-haskell/hdbc-2.4
22         >=dev-haskell/hdbc-postgresql-2.3
23         >=dev-haskell/hdbc-sqlite3-2.3
24         >=dev-haskell/missingh-1.2
25         >=dev-haskell/tasty-0.8
26         >=dev-haskell/tasty-hunit-0.8
27         || ( >=dev-lang/ghc-8.0
28                  ( >=dev-lang/ghc-7.10.1
29                    <dev-lang/ghc-8.0
30                    <dev-haskell/semigroups-0.18.2 ) )
31 "
32 DEPEND="${RDEPEND}
33         >=dev-haskell/cabal-1.16.0
34         test? ( >=dev-haskell/doctest-0.9
35                 >=dev-haskell/filemanip-0.3.6 )"
36
37 src_install() {
38         haskell-cabal_src_install
39         dodoc "${S}/doc/${PN}rc.example"
40         doman "${S}/doc/man1/${PN}.1"
41 }